04/01/2008

Commodore SX64 : partie 1

Voilà ! Je me décide enfin à poster en "avant-première" car je n'ai résisté à poster quelques images et quelques impressions sur ma dernière acquisition.

D'abord, je remercie Maxence Loré, le vendeur, pour son sérieux et sa rapidité d'envoi. Et pour avoir conservé le SX64 dans un excellent état.

Ensuite, première constatation : le poids ! Si on parle bien du premier portable couleur ayant jamais existé, on est plutôt dans la catégorie des transportables.

Après déballage, je branche le petit clavier tout mignon, qui se détache de l'avant et le connecte en dessous du SX64.

J'allume la bête, et comme par magie, l'écran si habituel du basic apparaît sur le minuscule mais très bon petit écran couleur (et non brûlé, ce qui n'est pas fréquent comme le soulignait Sandy).

Maxence m'a même fait la surprise de me donner une cartouche KCS power cartridge (une des meilleures cartouches de backup de l'époque). Cartouche que je m'empresse de tester, et qui fonctionne toujours parfaitement, comme le souligne la photo d'écran suivante.

 écran

Cet ordinateur a été fabriqué fin 1983 comme on le voit ci-après :

 date


Le numéro de série est le 4901. Apparemment, seulement 10000 de ces ordinateurs ont été vendus dans le monde, dont certainement une bonne partie sont en panne, ou ne fonctionnent plus correctement. Ce qui rend celui-ci encore plus "rare" :)

Le port cartouche est situé au dessus, derrière deux petits clapets qui le protègent de la poussière.

cartouche

Il n'est pas pourvu de sortie TV bien sûr puisque le mini tube cathodique est sensé remplacer la grosse tv du salon :)

A l'arrière se trouvent un port utilisateur, une sortie vidéo, une entrée/sortie série et deux ports joysticks.

Le petit clavier est entièrement fonctionnel. On y retrouve toutes les touches du commodore 64 bien sûr. Le cable qui le relie à l'unité centrale est de style "mini db25".

clavier

Voilà enfin une dernière vue d'ensemble du SX64.

 devant


A l'avant, du côté droit du drive pour être exact, se trouvent tous les réglages de l'écran à tube cathodique : contraste, clareté, couleur, et position verticale + un rêglage du volume sonore.

Me reste à tester le lecteur disquette et à poster quelques photos de jeux en fonctionnement !

A++++

Steph

PS: il possède également un petit haut-parleur et on peut y brancher un moniteur externe via la sortie "video" située à l'arrière.

13:16 Écrit par Steph dans Steph's Collection | Lien permanent | Commentaires (17) |  Facebook | | |  del.icio.us | | Digg! Digg

Commentaires

Belle machine... merde, tu va me faire regretter de ne pas l'avoir acheté ;)
Il a l'air en parfait état !!!

Il y a un haut parleur intégré ?

Une sortie video, on sait donc le brancher sur un moniteur ?

Écrit par : C64 | 04/01/2008

Il y a un haut parleur intégré, et oui, on sait le connecter sur un moniteur via la sortie video standard.
Effectivement il est dans un état proche du neuf !!

Steph

Écrit par : Steph | 04/01/2008

25 ans pfff Quand on pense que la bête à 25 ans et dans un etat pareil : il y a des gens qui savent prendre soin de leurs "affaires"...

Écrit par : C64 | 04/01/2008

Il y a un gros bémol tout de même : le lecteur de disquette ne fonctionne plus ... Bon... Pas trop grave dans la mesure ou j'ai connecté un lecteur 1541-II pour charger quelques jeux. Mais bon, j'aurais préféré une machine en parfait état de marche :) Sandy, sais-tu si c'est possible de réparer le drive ???

Écrit par : Steph | 04/01/2008

Tony was here. Merci de votre visite.
Lorsque j'ai acheté mon premier PC, en 1996, le vendeur me dit: "ça, c'est le bouton pour allumer!"
;-)

Écrit par : Tony | 04/01/2008

Floppy. Je ne crois pas que je suis assez qualifié pour t'aider, ceux que j'ai réparé jusqu'a maintenant avaient des pannes purement mécaniques (pattes, ressorts, levier, etc...)
Le premier truc qui me vient à l'idée est que sur le SX le drive interne n'etait pas adressé 8 , mais 0 (je crois), donc tu doit taper load"$",0 par exemple...
Si c'est pas ça, est-ce qu'il fait le bruit de "recherche" ou rien du tout ?

Écrit par : C64 | 04/01/2008

Device number Sinon, tu peux regarder ici :http://www.sx64.net/info/info_title_page5.htm
Il y a une section sur les problèmes de drive sur SX64. J'ai vu ailleurs que certains ont été vendus avec le numero de device 8 d'origine, et d'autres avec un autre numero ??? Bon maintenant si il réagit quand tu lance la commande avec ,8 c'est pas ça le pbl...

Écrit par : C64 | 04/01/2008

Il réagit bien quand je fais un LOAD "$",8,1 et semble chercher quelque chose, patine une ou deux fois puis termine avec un message d'erreur. La led du drive commence alors à clignoter ... j'ai l'impression qu'il s'agit d'un problème classique. Je vais aller vérifier ton lien ! Merci.

Écrit par : Steph | 05/01/2008

J'ai l'impression que le problème vient d'une de ces 2 puces. Si c'est la première, ça va être difficile à trouver. Si c'est la seconde, en principe, c'est encore trouvable facilement.

UF5 325572-01 MOTOR CONTROLLER (PLA)
When drive powered up or reset, red LED comes on and goes out,
but spindle motor does not turn. When LOAD attempted, spindle does not
turn, red LED flickers, screen displays "FILE NOT FOUND" and red LED
flashes.

UG4 7407 (7417) LOGIC (R/W CONTROL BUFFER)
When drive is powered up or reset from computer, red LED comes
on and goes out, but spindle motor does not turn. When LOAD is
attempted, stepper moves slightly, spindle doesn't turn, and error
message on screen is "FILE NOT FOUND" with flashing red LED. Partial
failure can produce write errors or no write.

Écrit par : Steph | 05/01/2008

Suggestion Une autre suggestion : Parfois quand je teste une nouvelle disquette que j'ai reçu, j'ai le pbl qui se produit avec la led qui clignote comme tu le décris, et après quand je remets mes bonnes disquettes, il les refuse toutes (même la lecture du DIR). Alors, je prends une disquette vierge, et je la reformate trois ou quatre fois, les premières tentatives sont refusées, et au bout de trois ou quatre fois, il accèpte de formater, puis si je remets mes bonnes disquettes, il les accèpte à nouveau : il semblerait que la manoeuvre de formatage permette de le réaligner dans certains cas. Ca peut arriver aussi quand j'ai transporté le drive (chocs) sans avoir mis le carton de protection (ou une disquette) dedans pendant le transport, je reformate, et il redémarre...

Écrit par : C64 | 05/01/2008

Nouvelle categorie J'ai ajouté une nouvelle catégorie de posts "Steph's collection", comme ça si tu veux exposer le reste de tes machines, on saura que c'est les tiennes...

Écrit par : C64 | 05/01/2008

Alors, réparé ? Tu a trouvé la panne ?

Écrit par : C64 | 06/01/2008

Pas eu le temps de regarder ça le weekend !
Mais je me suis amusé avec la carte MMC64 (que je vous recommande), j'ai mis tous les jeux C64 sur une seule carte MMC et je me sers du SX64 comme un "gros gameboy" (bon, d'accord, vraiment très gros :) ).

Écrit par : Steph | 06/01/2008

Apparemment il y a moyen de remplacer le drive du SX64 par un 1541. Ce sont les mêmes drives, excepté les connecteurs (il faut faire un connecteur 15 pins hors des 3 connecteurs du 1541). J'envisage de plus en plus cette possibilité. Mais je vais d'abord remplacer 3 puces, 2xLM592 et 1xLM311. Il y a de grande chance qu'un de ces 3 ICs (ou les 3) soi(en)t la cause de la panne ... Voilà, donc j'ai plusieurs possiblités pour réparer ce petit bijou!

Écrit par : Steph | 06/01/2008

J'ai commandé les pièces de rechange. En espérant que ça soit cela. Si la réparation ne fonctionne pas, je passerai à la méthode B (remplacement de tout le drive et la logique par un 1541).

Écrit par : Steph | 07/01/2008

Le lien Lemon : Si tu ne l'a pas encore trouvé :Va voir là :http://www.lemon64.com/
puis : Forum, général, "post here everytime you get new stuff", dernière page...

Écrit par : C64 | 09/01/2008

Bonjour,

J'en ai un chez moi, mais l'écran couleur fait des barres verticales; selon vous est-ce réparable?

Merci

Écrit par : LECOQ | 07/10/2010

Les commentaires sont fermés.