12/04/2009

Un peu de technique ...

Voici un petit article dédié à la réparation des machines Commodore.

Vous savez comme je peux être pugnace quand il s'agit d'arriver à réparer notre bécane préférée... En voici la preuve :)

En effet un de mes C64 en panne a comme symptome un écran de démarrage rempli de caractères "random". Le bord bleu de l'écran est normal mais l'intérieur est rempli de toutes sortes de caractères qui ont l'air d'avoir été choisi au hasard.

Voici une photo d'écran de la panne:

IMG_3763


Je remplace d'abord, par acquis de conscience, toutes les puces "classiques" par d'autres, qui fonctionnent dans un des mes autres C64 : 6526, VIC, 6510, ...

Toujours la même chose !

Suspectant un problème de mémoire, je me décide à placer des support CI en dessous de chacune des puces mémoires dont voici une image.

 

supports_mem

 

L'opération terminée, je peux maintenant remplacer chacune des puces mémoire par une autre, fonctionnelle. Voire même toutes simultanément.
Résultat: toujours le même problème !

Je procède à une autre technique: l'essai d'une cartouche.

Je possède en effet une cartouche diagnostique, qui permet de tester cpu, sid, mémoire, cia, ...

L'ennui c'est que mon écran, totalement brouillé par des caractères random n'arrange rien. Néanmoins, je peux voir que des caractères bougent de temps en temps. Cela veut dire que la cartouche fonctionne, que le cpu est ok !

Je peux même remarquer à l'endroit réservé aux tests des puces mémoire U21,U22,U23 et U24 des indications "BAD" ce qui signifie que quelque chose ne va pas avec ces puces.

Puisque toutes mes mémoires sont bonnes (je les ai toutes remplacées), il faut que j'aille voir autre part.

Je décide donc de remplacer une des puces MOS 7708 (équivalent 74LS257). Ces deux puces ont un rôle direct à jouer avec la mémoire, il suffit de regarder le schéma électrique du C64. C'est donc probablement une très bonne piste !

Voici une image de nouvelle puce placée sur son socket entourée en rouge (en dessous). Au dessus on peut voir la seconde puce, dédiée à la rangée des puces mémoires supérieures.

IMG_0338

Une fois remplacée, je redémarre le C64 et là, surprise ! L'écran de démarrage est bien fonctionnel ! Je lance un jeu à partir d'une disquette, nickel !
Le voilà de nouveau en ordre !

Voici la fautive (dont l'équivalent "cheap" est le 74LS257) :

 

IMG_0343

Maintenant que j'ai terminé de réparer celui-là, je me lance dans la réparation d'un autre donc le clavier a quelques problèmes (deux colonnes de touche ne fonctionnent plus). A priori je pensais qu'il s'agissait du CIA 1 mais après remplacement de celui-ci, toujours un problème similaire (mais autres colonnes de touche, ce qui me fait dire qu'il s'agit d'un problème mécanique, soudures sèches ou autre).

Bon amusement si vous vous lancez dans la réparation de votre Commodore et surtout, armez vous de patience. Dans mon cas, je n'ai pas compté les heures pour placer des sockets IC en dessous de toutes les puces suspectes. Il faut aussi faire preuve d'un bon esprit de déduction, et surtout, ne pas hésiter à mettre ses mains dans le cambouis !

Steph

23:20 Écrit par Steph dans FAQ et conseils | Lien permanent | Commentaires (6) |  Facebook | | |  del.icio.us | | Digg! Digg

Commentaires

Merci pour l'information. Cela peut toujours servire.

Écrit par : Axis | 14/04/2009

oui J'en ai un qui a exactement les mêmes symptomes, faudra que j'essaie, si j'ai la patience, dés que ma c-room sera un peu fonctionelle...

Écrit par : c64 | 14/04/2009

Ben voilà, si j'ai été utile à quelqu'un, je serai assez content !
J'en ai réparé deux autres: un dont le modulateur TV était défaillant, et un autre donc le VIC II était mauvais. Ces deux pannes-là étaient beaucoup plus faciles à détecter et réparer évidemment.
Dans tous les cas, c'est toujours possible de réparer virtuellement n'importe quelle panne.

Écrit par : Steph | 14/04/2009

Ah, je suis vert, j'avais un C64 avec les mêmes symptômes, et on m'avait orienté vers un problème de PLA... Depuis la CM est partie à la benne :(

Écrit par : frost | 14/04/2009

frost: pas de bol ! en plus c'est un composant vraiment bon marché :)

Écrit par : Steph | 14/04/2009

À la vue du sujet, je pensais qu'on allait parler du "retour" des C64 avec le 64bits :
http://www.commodoregaming.com/eu/home.aspx?q=18,25,1

Entre 1000€ et 4000€ la machine : ouch, ça fait mal.

Écrit par : ARme | 17/04/2009

Les commentaires sont fermés.