25/11/2010

Commodore 8032SK suite...La réparation

Je vous disais dans mon article précédent que j'avais le son mais pas l'image... Au démarrage du 8032SK des beeps retentissaient mais rien ne s'affichait à l'écran. D’après mes recherches sur internet, effectivement le PET fait du son au démarrage.

 

DSC05979.JPG

Je me décide de l'ouvrir pour pratiquer quelques tests avec ma probe logique, mon oscilloscope et comme d'hab le plan trouvé sur le net. Je me suis rendu compte que l'ordi avait l'air de tourner normalement.

En premier lieu j'ai testé le moniteur en branchant mon Pet2001 sur l'écran du 8032 et j'avais bien l'image de mon Pet2001 sur l’écran du 8032, je pouvais dores et déjà écarter la panne du moniteur.

 

DSC05984_60.jpg

Je soupçonnais le circuit vidéo, c'est un MOS 6545, et je trouvais qu'il chauffait assez fort. Je le dessoude et je place un support. Je cherche dans la liste de mon fournisseur de composants électroniques (www.mbtronics.com) si il aurait encore ce circuit et apparemment, il aurait encore de stock un circuit équivalent le 6845 de chez motorola. Je l'achète je rentre vite à la maison...je l'installe dans son support, j'allume et, et alors et alors et et..... rien toujours pas d'image.

D'après les sources que j'ai trouvées sur internet il existerait quelques différences entre le circuit MOS6545 et ses équivalents. Je me dis que c'est ces petites différences qui sont la cause que je n'ai toujours pas d'image. Je continue mes recherches et je trouve sur ebay aux Pays-bas un circuit vidéo 6545 du fabricant Rockwell mais il y aurait aussi quelques différences avec celui d'origine, tant pis, je risque, je l'achète le jeudi et le lundi c'est dans ma boite aux lettres. Vittttttte je teste.......Rien toujours pas d'image.

 

DSC05987_60.jpg

 

  Là je me dis que je dois arrêter de ma focaliser sur ce circuit et vérifier que la panne ne vienne pas d'un autre composant. En effet je remarque une anomalie sur la sortie (UC2 patte 8) d'une porte XOR d'un 74LS86 dont sa sortie est reliée au connecteur vidéo...

 

DSC05988_60.jpg

 

Je mesure un court-circuit entre la masse et la sortie de la porte. Je le dessoude, je le remplace...

 

DSC05985_60.jpg

 

Je rallume le 8032SK et ...

 

DSC05991_60.jpg

Quelle satisfaction. Merci Commodore pour les bons moments que tu me fais encore passer...

 

 

 

22:17 Écrit par Stephane dans Stephane's collection | Lien permanent | Commentaires (9) |  Facebook | | |  del.icio.us | | Digg! Digg

15/11/2010

Commodore 8032SK (Separate Keyboard)

Commodore 8032SK (Separate Keyboard)

Et un de plus dans la famille C=, il est arrivé tout chaud d'Allemagne dans sa boite d'origine...enfin j'espère

 

DSC05969_60.jpg

 

C'est toujours inquiétant lorsqu'un paquet arrive.. on se pose toujours la question suivante "Que vais-je trouver à l'intérieur de mon paquet", car acheter sur une photo avec une description en allemand c'est pas toujours évident. Assez discuté j'ouvre la boite...

 

DSC05971_60.jpg

Apparemment c'est bien un 8032SK même le plastique est d'origine. Je continue à déballer...

 

DSC05972_60.jpg

 

Belle surprise dans la boite , je trouve le manuel et en plus il est nickel...

 

DSC05974_60.jpg

 

Waouw . Il est encore bien conservé.. pratiquement neuf. Un petit test sur le 220V, On dirait qu'il démarre d'après les beeps sonores mais je n'ai pas d'image. Je pense qu'il y a une panne du côté moniteur mais sa réparation méritera un nouvel article...

 

DSC05976_60.jpg

Le 8032SK est sorti en 1979. Il est le premier à avoir un clavier séparé

CPU MOS 6502

Fréquence 1MHz

32Kb RAM

Le boitier a été dessiné par Porsche

 

DSC05975_60.jpg

La petite photo de famille...comme ils sont beaux

 

 

 

22:38 Écrit par Stephane dans Stephane's collection | Lien permanent | Commentaires (13) |  Facebook | | |  del.icio.us | | Digg! Digg

02/11/2010

Les 1541 de Max ...

Et bien comme je suis parti sur ma lancée d'écrivain, je vais vous faire partager la modification des lecteurs de disquettes 1541 de Max pour qu'ils fonctionnent avec le câble XAP1541 et le programme NibTools. Max m'a apporté deux lecteurs 1541 (un ancien modèle et le 1541 II) et en voici leurs modifications.

La modification consiste à reprendre le port 8bits d'un chip (MOS 6522) entreés/sorties interne au 1541 pour le relier au port imprimante d'un PC sur lequel tournera Nibtools.  DSC05901_50.jpg

Démontage du 1541 II pour localiser le chip 6522 afin de lui reprendre son port entrées/sorties 8bits inutilisé. 

DSC05902_50.jpg

 

Ah le voici, mince il n'est pas sur support... Faite chauffer la pompe à dessouder.

DSC05905_60.jpg

DSC05904_50.jpg

 Voilà plus qu'à souder le support...

DSC05906_60.jpg

Maintenant préparation du câble plat qui sera relié au connecteur 15 broches qui lui sera monté sur le boitier du 1541...

DSC05907_60.jpg

 

 

DSC05908_60.jpg

 

DSC05943_60.jpg

  Modicication du 1541 ancien modèle

 

 Confection du câble de transfert entre le 1541 et le PC

DSC05931_60.jpg

 Pour la réalistion de ce câble il nous faut 4 transistors BSV52 mais en boitier cms ... vite ma loupe.

DSC05936_60.jpg

 C'est pas petit, c'est minuscule ces bestioles là ..

 

DSC05941_60.jpg

 

Montage des transistors sur le câble. Ils vont être dissimulés sous le capot du connecteur...

DSC05942_60.jpg

 

 Voilà Max c'est quand tu veux pour tester ton matos avec Nibtools.

 

22:43 Écrit par Stephane dans Stephane's collection | Lien permanent | Commentaires (7) |  Facebook | | |  del.icio.us | | Digg! Digg

01/11/2010

Mon Pet 2001 avait un trou de mémoire...

 

Mon PET (Personnal Electronic Transactor ) avait un trou de mémoire...

 

 

DSC05927_50.jpg

 

Je n'avais pas encore de PET2001 dans ma collection et bien c'est fait j'en ai trouvé un. Il est vrai que celui de Max m'avait donné envie. Je l'ai acheté sur Ebay Belgique, après quelques échanges de mails avec le vendeur nous nous mettons d'accord sur le prix et l'heure du rendez-vous.

Me voilà parti de bonne heure vers Malines pour aller le chercher. Dès mon retour je me jette sur la première prise 220V venue, verdict, l'écran s'illumine, remplit de caractères aléatoires, pendant une seconde et puis plus rien... comme mort. Je l'éteins, j'le rallume, idem une seconde d'affichage et puis plus rien. Je brulais d'impatience de lui redonner la vie ...

DSC05919_50.jpg

Après quelques heures de recherche avec le schéma trouvé sur internet (merci internet), j'étais de plus en plus convaincu que le problème se situait du côté des RAM's. J'enlève toutes les mémoires de leurs supports sauf 1 kilooctet. Je le rallume et ... quel bonheur de revoir 1024 BYTES FREE. Je rajoute 1K à la fois et j'arrive à trouver la RAM défectueuse. Je les replace toutes sauf evidemment la défectueuse. Ce qui me donne un total de 6143 Bytes Free à la place des 7167 en fonctionnement optimum, Les RAMs du PET sont des MOS 6550 bien évidemment impossible à retrouver et oui le PET2001 date de 1977. Je recherche sa fiche technique sur le net pour en connaître un peu plus, c'est une 1K X 4bits. Je regarde dans mes pièces détachées et je retrouve une Ram 2114 de même équivalence qui était montée à l'époque dans les VIC20.

 

DSC05928_50.jpg

 Le probléme est que la 2114 est plus petite et n'a pas du tout le même brochage que la 6550. Et bien au boulot...

DSC05930_50.jpg

 La mémoire RAM de quelques Kilooctets du Pet avec la ram manquante…

DSC05910_50.jpg

 Adaptation de la 2114 à la place de la 6550 défectueuse sur mon protoboard.

DSC05923_50.jpg

Je rallume l’engin et …. ça maaaarche 7167 Bytes Free. Et bien il me reste qu'à confectionner le montage définitif.

 

 

 

DSC05913_50.jpg

 Un petit circuit imprimé avec quelques supports pour accueillir la ram et les ICs logiques.

 

DSC05915_50.jpg

DSC05914_50.jpg

 Un peu de câblage…

DSC05926_50.jpg

La mémoire défectueuse avec sa remplaçante…

DSC05916_50.jpg

 Et voilà le travail...

 

 

20:56 Écrit par Stephane dans Stephane's collection | Lien permanent | Commentaires (5) |  Facebook | | |  del.icio.us | | Digg! Digg